Investigating issues with the Zite editor

Incident Report for Zite

Resolved

This incident has been resolved and service is operating normally again. We’re continuing to review the root cause and identify improvements to help prevent similar issues in the future.
Posted Apr 20, 2026 - 18:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 18:01 UTC

Identified

Our team has identified the cause and is working on a fix. Certain published Zite apps are also experiencing slowness.
Posted Apr 20, 2026 - 17:48 UTC

Investigating

We are currently investigating this issue.
Posted Apr 20, 2026 - 17:36 UTC
This incident affected: Zite Apps.